通达信公式

加入日期:2011-8-2 21:50:57

 
源码如下:

狙击手
A:=(3*C+H+L+O)/6;
XJ:=(A+0.618*REF(A,1)+0.382*REF(A,2)+0.236*REF(A,3)+0.146*REF(A,4))/2.382;
YCZXH:=(MA(HHV(A,2),5)+MA(HHV(A,2),13)+MA(HHV(A,2),21)+MA(HHV(A,2),32))/4;
YCZXL:=(MA(LLV(A,2),5)+MA(LLV(A,2),13)+MA(LLV(A,2),21)+MA(LLV(A,2),32))/4;
SMH:EMA(YCZXH,21),COLOR004000,LINETHICK2;
SML:EMA(YCZXL,21),COLOR004000,LINETHICK2;
SMJ:(SML+SMH)/2,COLOR004000,LINETHICK2;
PJ:=(10*A+9*REF(A,1)+8*REF(A,2)+7*REF(A,3)+6*REF(A,4)+5*REF(A,5)+4*REF(A,6)+3*REF(A,7)+2*REF(A,8)+REF(A,9))/55;
A1:=EMA(PJ,3),COLOR004000;A2:=EMA(PJ,5),COLOR004000;
A3:=EMA(PJ,7),COLOR004000;A4:=EMA(PJ,9),COLOR004000;
A5:=EMA(PJ,11),COLOR004000;
LX:=REF(XJ,1);
ZD:=(SMA(MAX(XJ-LX,0),5,1)/SMA(ABS(XJ-LX),5,1))*100;
KX1:=(CLOSE>=OPEN) AND ZD>=50;
KX2:=(CLOSE<OPEN) AND ZD>=50;
KX3:=(CLOSE>=OPEN) AND ZD<50;
KX4:=(CLOSE<OPEN) AND ZD<50;
IF(A5<REF(A5,1),A5,DRAWNULL),COLOR820000,LINETHICK2;
IF(A5>REF(A5,1),A5,DRAWNULL),COLOR00005B,LINETHICK2;
IF(A4<REF(A4,1),A4,DRAWNULL),COLOR8C0000,LINETHICK2;
IF(A4>REF(A4,1),A4,DRAWNULL),COLOR000055,LINETHICK2;
IF(A3<REF(A3,1),A3,DRAWNULL),COLOR9B0000,LINETHICK2;
IF(A3>REF(A3,1),A3,DRAWNULL),COLOR00006C,LINETHICK2;
IF(A2<REF(A2,1),A2,DRAWNULL),COLORBB0000,LINETHICK2;
IF(A2>REF(A2,1),A2,DRAWNULL),COLOR00007D,LINETHICK2;
IF(A1<REF(A1,1),A1,DRAWNULL),COLORCC0000,LINETHICK2;
IF(A1>REF(A1,1),A1,DRAWNULL),COLOR00009B,LINETHICK2;
AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
BB1:=0;
B1ÍòÔª:=DVOL*DCLOSE/100;
B1²î:=B1ÍòÔª-REF(B1ÍòÔª,1);
B2ÍòÔª:=DVOL*DCLOSE/100;
B2±È:=B2ÍòÔª/REF(B2ÍòÔª,1);
¾»Á÷ÈëÍòÔª:=(AAA2-AAA3-0.5*AAA4);
PM:=MA(¾»Á÷ÈëÍòÔª,1);
PMA:=PM/REF(PM,1)>1;
PMB:=REF(PMA,1)<1 AND PMA;
ÃÜÂë:=(EMA(MA(B1ÍòÔª,2),2))/100000,COLORYELLOW,NODRAW;
¶þÈÕ±È:=ÃÜÂë/REF(ÃÜÂë,1);
Ñ¡¹É:=PMB AND ÃÜÂë>REF(ÃÜÂë,1) AND ¶þÈÕ±È>1 ,COLORRED,NODRAW;
¾ù¼ÛÏß:=AMOUNT/V/100;
¾ù¼ÛÏß2:=MA(¾ù¼ÛÏß,3);
¾ù¼ÛÏß5:=MA(¾ù¼ÛÏß,5);
¾ù¼ÛÏß10:=MA(¾ù¼ÛÏß,10);
¾ù¼ÛÏß30:=MA(¾ù¼ÛÏß,30);


STICKLINE (C>=O ,H,L,0,0)COLORRED;
STICKLINE(C>=O,O,C,2,1)COLORRED;
STICKLINE(C<=O,H,L,0,0)COLORLIGREEN;  
STICKLINE(C<=O,O,C,2,0)COLORLIGREEN;
STICKLINE(C=O,O,C,4,1),COLORWHITE;
STICKLINE(C=O,H,L,0,1),COLORWHITE;
Í»ÆÆ:=C>¾ù¼ÛÏß2 AND ¾ù¼ÛÏß2<REF(¾ù¼ÛÏß2,1) AND REF(¾ù¼ÛÏß2,1)<REF(¾ù¼ÛÏß2,2)
AND  REF(¾ù¼ÛÏß2,2)<REF(¾ù¼ÛÏß2,3) AND Ñ¡¹É;
STICKLINE(Í»ÆÆ,H,L,6,0),LINETHICK1,COLORWHITE;

STICKLINE(Í»ÆÆ,O,C,3,0),LINETHICK1,COLORMAGENTA;
STICKLINE(Í»ÆÆ,H,L,0,1),COLORMAGENTA;
MA1201:MA(CLOSE,120),LINETHICK1,COLORFF8888,POINTDOT;
MA60:MA(CLOSE,60)COLORLIGREEN,LINETHICK1,POINTDOT;
AA1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN)),NODRAW;
Ö÷Âò:IF(CLOSE>OPEN,AA1*(HIGH-LOW),IF(CLOSE<OPEN,AA1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),POINTDOT,COLORRED,NODRAW;
ÂòÅ̱ȣ¥:Ö÷Âò/VOL*100,POINTDOT,COLORWHITE,NODRAW;
RSV12:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,NODRAW;
K11:=SMA(RSV12,3,1),NODRAW;
DD1:=SMA(K11,3,1),NODRAW;
KK1:=INTPART(K11),NODRAW;
STICKLINE(ÂòÅ̱ȣ¥ >= 85 AND K11<50 AND DD1<50,O,C,3,0)COLORMAGENTA;
STICKLINE(ÂòÅ̱ȣ¥ >= 85 AND K11<50 AND DD1<50,H,L,0,0)COLORWHITE;



 
 
     
 

上一篇:邯郸成语故事之背水一战



下一篇:没有了